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. Infroduction

1.1. About

This document describes how to use the CDP redundancy functionality, with the RDManager system component,
to create redundant controller applications. The CDP Redundancy is a solution where one (active) controller is
running the application code, while one to three (standby) controllers are in standby, being updated by the
running controller. If the running controller fails, one of the standby controllers take over as the active controller.
This takeover happens within a time-interval of at least one process period, but may take more depending on how
the redundancy is set up. This means that the redundant application must be tolerant to lost 'samples' or 'runs', like
any other CDP application.

1.2. Terminology

RD
The redundancy and standby- functionality on CDP.

RDManager

RD functionality manager component model.

Companion controllers

Two or more controllers that contain an instance of the same virtual application.

Virtual application

Logical application space for components running in more than one physical controller.
IOServer

A component that handles Input/Output to something, typically (but not limited to) another external hardware
device.
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. Installation

2.1. Prerequisites

A valid CDP license

® Familiar with CDP

e CDP version: 2.3.1.0

® OS: “Windows” or “RTOS version 5.11” or “Linux (based on gcc-4.1.1 and glibc-2.3.6 or
glibe-2.6.1)”.

2.2. Quick setup of a project utilizing the Redundancylib library

1. Start CDP Developer

2. Make a new project by selecting File->'New Project', type in project name and click Create (or skip to
step 4 and open an already existing project in Visual Studio).

EI a Projects Path where project folder will be placed:
] GalaxyExplorer | C:\Projects | al
] HyperdriveEngine
] Lunalander Project name:
=2 C' Projecthame | RedundancyTest |

El {:I Application
: . el Components |~ Create project from the template below:

- +1- ] Models | C:VProgram Files\CDP De'u'eln::nper‘l,TempIates‘n,Praject_Ter| EI
I:I Pickures
] webServer CDPDeveloper
=~ {:I CDP_Application

l:l M Library
-] Spaceshuttle

Status: OK.

[

3. Choose Tools->'Open current project in DevStudio':
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s CDPDeveloper - [RedundancyTest]

File  Edit View | Tools i Help

0O = n % cﬁ Options
StartPage  Redunds Run current application 4 b =2

Open current project in DevStudio |

Ovenview Generator.exe rary

Library

Create new

Model

CDPB! - . . . - " . . X
FOWSET Exe ate a new library, including project files, library header include file and a
Runtime License Generator

e A Y

ControllerSetup not contain spaces or special characters.
Create new

Select existing Reporta bug that ends with Lib, for instance Spaceshiplib
add Library name

Signal
Parameter Create new library

Alarm

Message

State

State transition
Connector

Delete element

Component
Create new

Select existing

Model Documentation x|

4. If Visual Studio asks to convert the project, accept this by selecting 'Next'/'Finish'/'Close' until done.
Close the conversion report.
5. In Visual Studio, select the wanted configuration, like 'Release RTOS'.

¥« CDP_Application - Microsoft Visual S5tudio

File Edit WView Project Build Debug Tools ‘Window Community Help

H-EH-E A e # s % 9 - - B -2 b |Debug_COPUT [ win32

Solution Explorer - COP_Application ~ 1 X Debug
N Debug_CDPUL
& Debug_CDPUI_RTOS
Debug_RTOS
m Solution 'COP_Application' (2 projects) o
S B Debug_Safe
- 51 CDP_Application Debug_Safe_RTOS
EH Target Release

Release_CDPUI

Release CDPUL RTOS
R oE

Release_Safe RTOS
Configuration Manager...

6. Select 'CDP_Application' from the 'Solution Explorer', right-click and select Properties.
7. In C++/Additional Include Directories, make sure it says:
"$(CDPBASE)\RedundancyLib";"$(CDPBASE)\CDP";"$(RTTarget)\Include"
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CDP_Application Property Pages : :

Configuration: |ACﬁVE{RE|EBSE_RT05) V| Platform: |ACﬁVE(Wiﬂ32} V| [anﬁgurationManager... ]

(- Comman Properties Additional Include Directories "&(CDPBASE)\RedundancyLib™;"$(CDPBASE)\CDP";"¢
[=)- Configuration Properties
- General

& Debugons = RARIEY

- General $(CDPBASE) \RedundancyLib

- Optimization ${CDPBASE)\CDP
i §(RTTarget)\Include

Additional Include Directories

- Preprocessor

- Code Generation
- Language <
- Precompiled Headers —
- Qutput Files

- Browse Information Inherited values:
- Advanced

- Command Line

- Linker

H- Manifest Tool
t-Resources

t- XML Document Generator
- Browse Information

- Build Events

- Custom Build Step Inherit from parent or project defaults

t- Web Deployment

Iif |

%

[rrm I ey O s T O ey IO e O IO

[ oK ] [ Cancel n delimited list if more than one,

=

[ oK ][ Cancel l Apply

The compiler will look in the directories specified in 'Additional Include Directories' for files that you
#include in your .cpp and .h files. If you get an error 'Can not open include file...", then it is most likely
caused by a missing include directory, or that the file you #include does not exist.

8. In Linker->Input, make sure you list RedundancyLib Release RTOS.lib CDP_Release RTOS.lib in
addition to all the on-time rtos32 libraries you need. This will ensure that the linker finds all the
functions that are referenced in the code.
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CDP_Application Property Pages

Configuration: |AL‘tiVE{ReIease_RTOS} v | Flatform: |Atﬁve[Win32} hd | [ Configuration Manager... l
(- Commen Properties Additional Dependencies Redundancylib_Release_RTO05.lib CDP_Release_RTC
(=) Configuration Properties __ ) =] 73

- General Additional Dependencies
Debugging Redundancylib_Release_RTOS.lb
G- CfC++ COP_Release_RTOS.lib
[=)- Linker rifiles.lib
tsk32.lib
fe"'etra' ipdb tion@4,_RTFileSystemlList
”p“,fe . rtk32s b
- Mani slt File Flipii.lib
- Debugging Hrtpent.lib
- System Clkpc.lib
- Optimization d&“‘;ﬁ%"b
- Embedded IDL s
- Advanced
(;ommand Line Inherited values:
[#- Manifest Tool -
[+]- Resources tzg:;g’ﬁ;'b i’
[#- XML Document Generator qdiz2, i
[#- Browse Information winspoal.lib
(- Build Events comdig32.ib =
- Customn Build Step advapi32.lib
[#- Web Deployment ][
piay Al ole32.lib ||
oleaut32.lib i
q | wuid.ib an (e =i
N Inherit from parent or project defaults Macros=>>
= Cancel Apply

. L e

9. In the 'Solution Explorer', inside the 'CDP_Application' project, locate the Header file 'Libraries.h', and
add the line
#include <RedundancyLib.h>

@% CDP_Application - Microsoft Visual Studio

Fie Edit View Project Buld Debug Tools Window Community Help

ugn R RN = R EENE N R + 2L b Release_RTOS + Win32 ~ | [# EncodelnsignedInte4
Solution Explorer - Solution 'COP_Application’ (2 proj... » & X || libraries.h
@ |{Global Scope)
:[JSqution 'CDP_Application’ (2 projects) B// To use libraries, do the following:
=+ (31 cop_Application // 1) add an include for the lib below (Typically Yo
& @HeaderFlles f/ 2) Bdd the directory where the library library pa
@cgpsﬁrf'h //  the project that builds this file (CDP_Applica
ﬁ“ ra”es'h // 3) Set the project that builds this file (CDP App
Iﬂ ;E:L;;c: Iz of your lib project, or add the lib to the lin
_____ £ Model Fies /o CDP_Application project.
- [ Source Files _
Iﬂ COP.ico #include <Redundancylib.h>
B @ iconLico
@iconz.ico //{ CodeGenerator: Insert library includes here
[ @Target -

10. If there is no 'Target' project in your 'Solution Explorer, select 'Solution’->'Add'->'Existing Project'.
Choose the 'Target.veproj' from the same folder in which your 'CDP_Application.veproj' is at.

11. Right-Click Solution, select 'Configuration Manager...". Make sure that all configurations have
'Release RTOS' selected in 'Configuration':
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Configuration Manager

Active solution configuration: Active solution platform:
Release RTOS v | |win32 v |

Project contexts (chedk the project configurations to build or deploy):

Project Configuration Platform Build
CDP_Application Release_RTOS »  Win32 w
Target Release RTOS Win32

Close

12. Choose 'Solution'->"Project Dependencies...", choose 'Target' from the pull-down list, check
'CDP Application' and click OK.

Project Dependencies

Projects:

|Target W

Depends on;
[w] COP_Application

[ Ok, ] [ Cancel

13. Rebuild the entire solution to generate the CDP.rtb file in the CDP_Application\Release RTOS\ folder.
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3. Prepare components

3. ] . Overview

3.1.1. Must

Serialization must be implemented on all components running redundant.

repare components for redundanc

If the component does not have any custom members, such as stl lists or int or arrays, but only CDPObject-
derived members like Signal<T>, then it is not necessary to extend the serialization as this is already handled in
the CDPComponent base class. Note that timers will not be Serialized by the CDP base, you will have to do this
yourself.

3.1.2. Custom serialization

Custom serialization is made by overriding methods Serializeln(...) and SerializeOut(...), adding copying in and
out for all custom members that need to be synchronized.

3.2. Serialization basics

The serialization of objects is handled by the InputStream / OutputStream classes.

These classes implement all the basic operators needed for serialization, and contain a pure virtual function to do
the actual transport of the serialized data. These functions ( WriteStreamData() and ReadStreamData() ) must be

overridden by derived classes. CDPUDPInputStream and CDPUDPOQOutputStream are such derived classes; they

implement a transport layer on the UDP Multicast protocol.

The InputStream class implements the following operators:

virtual

virtual
virtual
virtual
virtual
virtual
virtual
virtual
virtual
virtual
virtual
virtual
virtual
virtual

InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&
InputStreamé&

operator>>(bool &bData);
operator>>(char &chbData) ;
operator>>(unsigned char &chData);
operator>>(short &nData);
operator>> (unsigned short &nData);
operator>>(int &nData);
operator>>(unsigned int &nData);
operator>>(long &nData) ;
operator>>(unsigned long &nData);
operator>>(float &fData) ;
operator>> (double &dData) ;
operator>>(int64 t &uiData);
operator>>(uint64 t &uiData);
operator>>(std::string & strData);

The output stream implements the reverse operators:

virtual
virtual
virtual
virtual
virtual
virtual
virtual

OutputStreamé&
OutputStreamé&
OutputStreamé&
OutputStreamé&
OutputStreamé&
OutputStreamé&
OutputStreamé&

operator<<(bool & bData);
operator<<(char & chbhata);

operator<< (unsigned char & chData);

short & nData);

operator<< (unsigned short & nData);

operator<<(int & nData);

(
(
(
operator<< (
(
(
operator<< (unsigned int & nData) ;
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virtual OutputStreamé& operator<<(long & nData);

virtual OutputStreamé& operator<<(unsigned long & nData);
virtual OutputStreamé& operator<<(float & fData);

virtual OutputStreamé& operator<<(double & dData);
virtual OutputStream& operator<<(int64 t & uiData);
virtual OutputStreamé& operator<<(uint64 t & uiData);
virtual OutputStreamé& operator<<(std::string & strData);

All CDPObjects and CDPObject-derived classes contain these two virtual functions:

virtual OutputStreamé& SerializeOut (OutputStream& outstream) ;
virtual InputStreamé& SerializelIn (InputStreamé& instream);

SerializeOut(...) is used to transport data from this object to another object.
Serializeln(...) is used to transport data from another object to this object.

The following CDPObjects are serialized automatically from a CDPComponent: Signals, Alarms, Parameters,
local connectors, parent connector, and remote connectors. States are also serialized.

Other objects must be serialized manually. Example:
Assume you have a CDPComponent, named MyComponent, which has a CDPTimerMs and 5 double types.
To serialize these objects, you must:

1. Add the serialization functions to the CDPComponent derived class header file:

class MyComponent: public CDPComponent
{

public:
virtual OutputStream& SerializeOut (OutputStreamé& outstream);
virtual InputStreamé& SerializelIn (InputStreamé& instream);

CDPTimerMs m_Timer;
double m dl,m d2,m d3,m d4,m d5;

}i
2. Implement the Serialization functions in the CDPComponent derived class cpp file:

OutputStream& MyComponent::SerializeOut (OutputStream& outstream)
{

// always call base first

CDPComponent: :SerializeOut (outstream) ;

// Serialize Timer:
m Timer.SerializeOut (outstream);

// Serialize doubles:
outstream << m_dl;
outstream << m d2;
outstream << m_d3;
outstream << m d4;
outstream << m_d5;

// Always return stream.
return outstream;

InputStream& MyComponent::SerializeIn(InputStream& instream)

// always call base first
CDPComponent: :SerializelIn (instream) ;

// Serialize Timer:
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m Timer.SerializelIn (instream);

// Serialize doubles:
instream >> m dil;
instream >> m d2;
instream >> m d3;
instream >> m d4;
instream >> m d5;

// Always return stream.
return instream;

If you for have an array that must be serialized, or some other type that is not directly supported by the streaming
operators, it is advised that you serialize the size first, and then serialize <size> elements. Note that CDP
automatically handles network conversion of data types >byte, so you do not need to worry about endian-ness
incompatibility.

You should also note that the order of the objects is the same regardless of serialization direction (in or out), see
example above.

There are two types of serialization:

Fast-sync: This is serialization that happens at a specified interval (SynchFs). Only non-persistent data is
synchronized to minimize transport time and amount of data.

Slow-sync: This is serialization that happens when a persistent value has changed. The slow-sync actually
happens after an xml-file for a redundant component has been write modified. This happens regardless of
redundancy state. If you upload a new xml-file belonging to a 'Standby' (or 'Active') component, this file will be
automatically distributed to the other companion(s).

To distinguish between slow-sync and fast-sync, there is a method in the InputStream and OutputStream objects
that can be called to determine whether it is performing fast or slow synchronization:

if (instream.ShouldDoPersistentDataOnly () )
{
// do all persistent values

}

else

// do non-persistent values...

}

3.3. CDPUDPInputSiream / CDPUDPOuUtputSiream

Note: The following information is technical and is not required to understand to use the redundancy solution.
However, there are some limitations you should be aware of, see Limitations in chapter 4.3.2

These two classes contain the actual transport layer for the synchronization. The SerializeIn and SerializeOut
functions will be allocated a certain time to run to avoid blocking. The implementation is like this:

The SerializeOut function will build all serialized data into one buffer. This buffer will be transmitted as one or
more UDP packets (depending on size). Each UDP packet is 1032 bytes (1024 bytes data + 8 bytes header).
After all packets are sent, the remaining time will be used for waiting for NACK (negative acknowledge) on any
of the packets, and resending the last packet. If one or more nack(s) is received within the allocated time, the
nack'ed-packets will be re-sent.
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The Serializeln function will wait for data. If packet == expected packet, receive packet and increase expected
packet. If packet > expected packet , receive packet and send NACK for packets [expected packet, got packet> ,
increase expected packet. If packet < expected packet and a resend, receive packet.

The reasoning to use negative acknowledgment is as follows: This allows us to have one sender and many
listeners without needing a lot of bandwidth, and it's a simpler implementation than the 'ack' approach. Due to the
nature of UDP, packets can (and probably will) be lost. If we were to send an acknowledgment for each packet,
the sender would need to know how many listeners it had, and it would need to have a way of identifying these
listeners. It would be a more complex protocol, less deterministic, it would be slower (due to resend/packet loss)
and require more bandwidth than the nack-approach.

Example showing the 'Nack' approach (sending 5 packets):

Sender: Receiver X:
packet 1 == packet 1

(timed wait for a packet)
packet 2 -X=-> no receive

(timed wait for a packet)
packet 3 -X-> no receive

(timed wait for a packet)
packet 4 -X=> no receive

(timed wait for a packet)
packet 5 === packet 5

done sending.
wait for nacks:

NO <-X- resend packet (2,3,4)
(timed wait for a packet)
packet 5 -—> (ignore, already got it)
OK <--- resend packet (2,3,4)
(timed wait for a packet)
packet 2 == packet 2
OK <—--= resend packet (3,4)
(timed wait for a packet)
packet 3 -X-> packet 3
OK <—-= resend packet (3,4)
(timed wait for a packet)
packet 4 === packet 4
OK <—--= resend packet (3)
(timed wait for a packet)
packet 3 -——=> packet 3

(got all packets), done.

packet 5 -——=> (not listening)
(waitédnack)

packet 5 —-——> (not listening)
(waitédnack)

packet 5 ===> (not listening)

(time is up, done).

The last packet is re-sent at most 10 times if no 'nacks' are received. This is to ensure that all listeners get the last
packet and to ensure that they have a possibility to send 'nack's for packets they are missing. If there is very little
time left after sending the initial batch of packets (i.e. less than Sms), the last packet is at most re-sent only three
times.
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3.3.1. Packet Format

The packet format for send-packets:

unsigned char Version number (0x01)

unsigned char sequence number (0-255)

unsigned short Total number of packets in this sequence
unsigned short Packet number in this sequence
unsigned short packet length

array packet length of data

The packet format for 'nack' packets:

unsigned char Version number (0x01)

unsigned char sequence number (0-255)

unsigned short Total number of packets to nack (logical OR with 0x8000)
unsigned short Packet number 1 to request

unsigned short Packet number n-1 to request

unsigned short Packet number n to request

3.3.2. Limitations

Since the packets sent out may also be received by the sender, a way of distinguishing between send-packets and
‘nack’ packets must exist. It has been chosen that the 'total number' should have its high bit set if it is a 'nack’
packet. Since the total number of packets to ack is logically or'ed with 0x8000 (msb is set), this effectively limits
the number of packets to send to 32767 packets. Each packet is 1024 bytes of actual data, so this yields a
maximum of 1024*32767 bytes of data, which is slightly less than 32 MB of data for each SynchFs. However,
unless the SynchFs is far below 'l', this number is purely theoretical on today's systems. Note that the sender and
receiver will require a lot of memory to handle this amount of data.

As the transport protocol is UDP, there is no guarantee that all packets arrive at the receivers. Depending on the
send-frequency and amount of data to send, less time might be allocated to the 'wait4nack' loop. A low send-
frequency (SynchFs) and low amount of data to send increases the chances of successful transmission. The
RDManager SerializeCounter can be monitored on all RDManagers to see if they follow the active RDManager:

QlERE ]

— [%] SerializeCo
— [#] SerializeCow

192-

128 -

84 -

Clear [@ ]

Save [1Z:50:45 | [_Eeslart [®] vurap +[7.2698] =
Load [®][F][#ed Feb 06 2008 | | |_Real- fime] [ Owerwrite
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For the slow synchronization, specify the maximum time allowed to perform a slow-sync. If this time is set too
low, the slowsynch might never succeed. This timeout-value should be set to at least 5 times the time needed to
send the largest component XML file.

Assuming 100Mb/s network speed, and CPU able to cope, the practical network speed using our protocol is
around 8MBytes/s. If the network-load is high, slower transfer rates are plausible due to more collisions and
packet-loss in switches. Assuming your largest component file is 500 KB would compute to a theoretical slow-
sync speed setting of around 0.07 seconds. Since we never want the slow-sync to fail you should add a good
margin to this number; so round up to the nearest 0.1 seconds to be sure. Setting this value too high will cause
delays to the slowsynch of the other redundant components.
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